Peer dependency to react 17

This issue has been tracked since 2021-10-02.

Need to upgrade peer dependency to support react 17. https://reactjs.org/blog/2020/10/20/react-v17.html

cesargdm wrote this answer on 2021-12-30

Getting errors while trying to install with npm install

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/react
npm ERR!   [email protected]"17.0.2" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer [email protected]"15.x || 16.x" from [email protected]
npm ERR! node_modules/react-email-editor
npm ERR!   [email protected]"1.5.0" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR! See <...>/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     <...>/.npm/_logs/2021-12-30T01_26_53_000Z-debug.log
ljrodriguez1 wrote this answer on 2022-03-23

Hello Do we have an update on this! would be awesome to be able to have react 17 on peer Deps

KennethSylar wrote this answer on 2022-03-26

hi, is there an update to support react 17 for this package ?

sonnguyent2 wrote this answer on 2022-04-08

@ayushmxn @umairsiddique I saw the source code already add support for React 17 but the npm package (1.5.0) is not republish with new code so the issue still happen. Could you please publish the package with latest code ?

ayushmxn wrote this answer on 2022-04-08

@sonnguyent2 you can use this package along with React 17. I didn't encounter any breaking changes. Whenever you install dependencies, it'll just show a peer dependency warning.

monomy001 wrote this answer on 2022-04-10

nope.. not true..

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/react
npm ERR! [email protected]"^17.0.2" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer [email protected]"15.x || 16.x" from [email protected]
npm ERR! node_modules/react-email-editor
npm ERR! [email protected]"*" from the root project

69 vulnerabilities (17 low, 26 moderate, 24 high, 2 critical)

lucasbesen wrote this answer on 2022-04-18

Support to React 17 is now live

More Details About Repo
Owner Name unlayer
Repo Name react-email-editor
Full Name unlayer/react-email-editor
Language JavaScript
Created Date 2017-10-01
Updated Date 2022-12-05
Star Count 3598
Watcher Count 48
Fork Count 627
Issue Count 163

YOU MAY BE INTERESTED

Issue Title Created Date Updated Date