Broken peer dependency with React 18

This issue has been tracked since 2022-06-09.
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: [email protected]
npm ERR! Found: [email protected]
npm ERR! node_modules/react
npm ERR!   [email protected]"^18.0.0" from the root project
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer [email protected]"15.x || 16.x || 17.x" from [email protected]
npm ERR! node_modules/react-email-editor
npm ERR!   [email protected]"^1.6.0" from the root project
redasys wrote this answer on 2022-07-07

This worked for me. Add this to your package.json:

"peerDependencies": {
"react": "15.x || 16.x || 17.x || 18.x"
},

Not ideal, but works...

eviltik wrote this answer on 2022-07-07

@redasys thx for the tips, when you say "package.json", are you speaking about local package.json project or react-email-editor one ? I've tried both without luck.

eviltik wrote this answer on 2022-07-07

@adeelraza hi, is it possible to release a version for react 18 ? ty

More Details About Repo
Owner Name unlayer
Repo Name react-email-editor
Full Name unlayer/react-email-editor
Language JavaScript
Created Date 2017-10-01
Updated Date 2022-12-05
Star Count 3598
Watcher Count 48
Fork Count 627
Issue Count 163

YOU MAY BE INTERESTED

Issue Title Created Date Updated Date