vuejs/vue-migration-helper: CLI tool to aid in migration from Vue 1.x to 2.0

594
STARS
50
WATCHERS
65
FORKS
6
ISSUES

vue-migration-helper's Language Statistics

vuejs's Other Repos

Star history of vue-migration-helper
Issue history of vue-migration-helper

vue-migration-helper Recent Issues

Issue Title State Comments Created Date Updated Date Closed Date
vue3 migration support open 0 2021-03-01 2022-09-25 -
vue-router version comparison open 0 2020-03-27 2022-10-05 -
Package version constraint parsing seems off closed 3 2019-02-15 2022-09-28 2019-03-03
bash: vue-migration-tool: command not found closed 1 2018-07-10 2022-10-02 2018-07-12
.sync modifier is valid since v2.3.0+ open 1 2018-04-05 2022-10-03 -
Add detection of router.beforeEach() without calls to next() open 2 2017-08-03 2022-09-28 -
Can't run the migration-helper closed 1 2017-05-25 2022-09-28 2017-05-25
Detect when events in html use `$arguments` open 1 2017-05-10 2022-09-28 -
Detecting gulpfile globs as Vue Router routes closed 1 2017-04-26 2022-10-03 2017-05-07
[proposal]add `autofix` option closed 1 2017-04-01 2022-10-06 2017-05-07
Add check for interpolated value in "value" attribute closed 2 2017-02-20 2022-09-28 2017-02-21
vue-migration-tool vue-migration-tool runs out of memory closed 2 2017-01-28 2022-10-05 2017-01-29
check-for-deprecations.js -> TypeError: Cannot read property 'some' of undefined closed 11 2016-11-01 2022-09-28 2016-11-02
problem with detecting `value=""` closed 1 2016-10-31 2022-10-06 2016-10-31
helper is also reading unrelated files ex. .scss closed 8 2016-10-24 2022-10-05 2016-10-31
Set up check for update before running, so that users will always have up-to-date rules closed 1 2016-10-13 2022-10-02 2016-10-23
Add Vuex 1.0 Deprecations closed 0 2016-10-13 2022-10-04 2016-10-23
Suggest Dependent Versions closed 0 2016-10-12 2022-10-06 2016-10-13
install error closed 2 2016-10-11 2022-01-02 2016-10-11
Assistant finds deprecations in images. closed 1 2016-10-05 2022-09-28 2016-10-07
Command failed: git -c core.longpaths=true config --get remote.origin.url closed 2 2016-10-04 2022-10-01 2016-10-11
why install from git instead of npm? closed 3 2016-10-04 2022-09-29 2016-10-05
Support files as arguments closed 1 2016-10-01 2022-09-28 2016-10-13
Better detection within Laravel's .blade.php files open 5 2016-10-01 2022-10-01 -
Detecting comments as Vue Router routes. closed 5 2016-10-01 2022-10-03 2016-10-01
Null exception during first run closed 4 2016-10-01 2022-10-05 2016-10-01
Tool does not detect changes in *.vue component files. closed 4 2016-09-30 2022-10-02 2016-10-01
Cannot read property 1 of null closed 6 2016-09-30 2022-09-30 2016-10-01
[Error] Wrong more info link closed 2 2016-09-27 2022-09-28 2016-09-27
Perhaps introduce a flag (e.g. --pessimistic) that includes any *possible* deprecations closed 8 2016-09-21 2022-09-28 2017-05-10
`require` path error related to `recursive-readdir-sync` closed 1 2016-09-19 2022-09-28 2016-09-19
Add Vue-Router Deprecations closed 14 2016-09-17 2022-09-28 2016-10-13
Add Vuex 2.0 Deprecations (lower priority, as upgrading to Vuex 2.0 is optional for Vue 2) closed 9 2016-09-17 2022-09-28 2017-05-10
Modules support closed 2 2016-09-16 2022-01-22 2016-09-16